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By Dick Eassom

The Problem
First, many thanks to those of you who attended either of

the sessions that Suzanne Kelman and I gave at the

recent APMP Conference in New Orleans. We really

appreciated the turnout, and your questions and interac-

tion. In our first session, a three-hour tutorial workshop

entitled “Microsoft Word Templates 101,” we went

through all the steps necessary to set up an attractive,

robust and compliant template for a proposal. However,

as we prepared our handout material, we realized that one

aspect of template creation deserved further work—the

use of automatic heading numbering styles.

For those of you who have ventured into this feature, and

felt safer with manual numbering, you are missing out on

several key benefits of automatic numbering:

■ Newly inserted headings adjust themselves (and subse-

quent headings) to the correct number in the heading

sequence

■ Generating (and updating) a table of contents is

really easy

■ Modules distributed to contributing authors can be

made to start at correct heading number

■ Defined heading styles make formatting easier and

more robust

■ Cross references to other sections are easy to add

and maintain

Nevertheless, I can understand your trepidation—I used

to have problems with header formatting going haywire,

and heading level numbering not following the sequence

I expected.

The formatting craziness is due to a conflict between

the paragraph formatting, held by the Heading X style,

and the heading formatting, held by the numbering

list gallery. 

The Solution
There is a consistently safe way to create automatic head-

ing numbering, which I have described below. If you fol-

low this, you should be safe!

continued on next page ◗
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Set Up the Heading Styles

Go to Format > Styles and Formatting…, or click 

Styles and Formatting on the Formatting toolbar to

display the Styles and Formatting task pane in Word

2002 (Office XP) and Word 2003. By default, you will

have Heading 1 through Heading 3. Click Modify… on

the dropdown next to Heading 1 to display the Modify

Style dialog. Select (no style) in the Style based on

dropdown—basing your styles on (no style) ensures that

they will not be corrupted by a different Normal style on

another computer. Select Body Text, rather than

Normal, in the Style for following paragraph dropdown

for the same reason:

Click Format at the bottom of the dialog, click Font…

on the dropdown list, and select the desired font settings

in the Font dialog. Click Paragraph… on the Format

dropdown list and select the desired settings on the

Indents and Spacing tab of the Paragraph dialog.

However, do not change the Indentation settings from

those shown below, as we will set these up later. You may

also want to select the settings on the Line and Page
Breaks tab:

Click OK on the Modify Style dialog when you’ve fin-

ished with the Heading 1 settings. Word will automati-

cally add Body Text to the list of available styles—you

can edit this style later. Now edit the Heading 2 style.

Select Heading 2 in the Style based on dropdown.

Similarly, base Heading 3 on Heading 2, etc. This sets

up a hierarchy through the heading styles. Remember to

select Body Text in the Style for following paragraph
of each heading style. To edit Heading 4 through

Heading 5, select All Styles in the Show dropdown at

the bottom of the Styles and Formatting task pane. Set

the Show dropdown back to Available Styles when you

have finished, and close the Styles and Formatting task

pane.

Set Up the Automatic Numbering

Check the formatting of all your heading styles using

some dummy heading and paragraph text. When you’re

happy with the look and feel of your template, we can

now set up the automatic numbering.

I strongly recommend that you ensure that Field
shading is set to Always once you start using automat-
ic numbering, since Word uses fields to provide these
features and it is extremely useful to differentiate from
text that you typed and Word created automatically!
Go to Tools > Options and, on the View tab, set
Field shading to Always, then click OK.
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Go to Format > Bullets and Numbering… and select

the Outline Numbered tab on the Bullets and
Numbering dialog. The closest list (in terms of the num-

bering style used in proposals, also known as legal-style

numbering in Word) in the outline-numbered gallery is

second from left on the bottom row (this is list number 5,

counting from zero). The view of the dialog shown below

has all the lists in their default state. You can return any

list to this state by selecting it, and then clicking Reset
at the bottom left of the dialog:

Click Customize… to display the Customize Outline
Numbered List dialog. Before we move on to setting up

the numbering scheme, let’s spend a minute on each fea-

ture on the dialog. Firstly, click More to display the nor-

mally-hidden bottom part of the dialog:

■ Level shows the heading level whose details are cur-
rently displayed on the dialog, e.g. heading level 4 in
the example

■ Number format shows the way the heading number
will appear for that level, in a confusing, Word-like
way, e.g. 1.1.1.1 for heading level 4. The gray-shaded
text represents the value of the relevant heading level,
automatically generated by Word—anything else is
plain old text. So, 1.1.1.1 represents “Starting value of
the heading level 1, followed by a period, followed by
the starting value of heading level 2…” and so on. For
those of you that enjoy poking around under the hood,
Word stores the number format using %x, where x is
the heading level. So the heading level 4 number for-
mat above would be stored as “%1.%2.%3.%4” which
makes a lot more sense.

Therefore, do not assume that the third gray-shaded 1
is the starting value of heading level 3, when you’re
looking at the level 4 format of 1.1.1.1. When all the
levels start at 1, it is all to easy to start editing this
value and getting the heading level values out of
sequence. If this happens, your best bet is to go back to
the Bullets and Numbering dialog and reset the list.

■ Number style shows the way that the heading level
will be displayed, i.e. as an Arabic number (1, 2,
3,…), a letter (a, b, c,… or A, B, C,…), a roman num-
ber (i, ii, iii,… or I, II, III,…), or one of many other
formats. It is also possible to have None, where no
value will be displayed. Deleting the gray-shaded value
in Number format for a level will also set the
Number style for that level to None.

■ Start at displays the value of that heading level of the
first heading in the document to use that heading
level. For example if heading level 1 starts at 2 and
heading level 2 starts at 2, then the first heading level
2 in the document will be 2.2. This can be used to
split up large documents, but there is actually a better
technique—see below!
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■ Previous level number is used for inserting the value
of a previous heading level into the number format.
For example, let’s suppose that heading level 4 number
format is blank. We could recreate the default value by
clicking Previous level number 1, followed by typing
a period, followed by clicking Previous level number 2,
etc. As I said, it’s easy to get these things messed up.

■ Number position displays where the automatically
generated heading number will appear on the line, i.e.
left, center or right aligned. You will normally want to
select Left.

■ Aligned at is the distance between the left margin
(for left aligned numbers) and the actual numbers, e.g.
0.5” indents the numbers 0.5” from the left margin.

■ Tab space after is the tab stop position where, if you
follow the number with a tab character (see Follow
number with below), the heading text will start. You
will have to set this to allow for the text length of the
largest number you are likely to use.

■  Indent at is the indent of the second and subsequent
lines of the heading text from the left margin. This
equivalent to a hanging indent on the Paragraph dia-
log, and you will normally want to set this to the same
value as Tab space after.

■ Link level to style is used for tying a particular head-
ing level numbering scheme to an actual style.
Conventionally, heading level 1 is tied to the Heading
1 style, heading level 2 to the Heading 2 style, etc. Of
course, there is nothing to stop you doing something
else, so beware…

■ Legal style numbering, when checked, will disable
the Number style dropdown and override the setting
to Arabic numerals, i.e. 1, 2, 3,…

■ Follow number with selects the character between
the automatically-generated heading number sequence
and the actual heading text, and can be a tab, a space
or nothing.

■ Restart numbering after should be checked to make
sure that each level restarts from the Start at value
when the higher-level heading value changes to ensure
you get the correct sequence. Thus, heading level 4
resets to its Start at value after a new heading level 3.

■ ListNum field list name allows you to give your num-
bering scheme a name.

Hopefully, that sheds a little light on what is a very busy
dialog box! Once you have set up your headings, click
OK to close the dialog. You will see that your Heading X
styles have been updated with the numbering scheme you
set up. What you must not do at this stage is to reenter
any of the Heading styles through Modify > Paragraph,
otherwise Word will mess up all the heading styles!

Now you have set up automatic numbering, you can cre-
ate your document headings simply by applying the rele-
vant style.

Creating a Table of Contents

Now you have automatic numbering, this couldn’t be
easier! Create an empty page at the start of the document
where you want to place your table of contents (ToC).
Go to Insert > Reference > Index and Tables…, and
select the Table of Contents tab on the Index and
Tables dialog:

By default, if you simply click OK, you’ll get a table of

contents containing hyperlinks to the first three levels of
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headings. You can adjust the levels by selecting the value

of Show levels. By all means play with the values of the

Formats dropdown, but I suspect that you will rapidly

come back to From template as the best option. You

may want to change the format of the ToC entries—once

upon a time, ToC styles were listed along with all the other

styles, but since Word 2002 have been accessed through

this dialog. Click Modify… to display the Style dialog:

The one change you should make to your TOC styles is

to base the TOC 1 style on (no style), the TOC 2 style

on TOC 1, etc. Click Modify… to change the style’s para-

meters. You only need to fix the TOC styles that you’re

going to be using in your ToC.

After your ToC has been created, you can update it by

placing the cursor inside the ToC and pressing F9

(update fields). Word will display the Update Table of

Contents dialog:

Select Update entire table (even if you haven’t added

more headings since the last time you updated the ToC)

and click OK.

Figure Captions

Now you have automatic numbering in your headings,

you should also be using automatic numbering in your

figure captions. To insert an automatically numbered cap-

tion, go to Insert > Reference > Caption… Word dis-

plays the Caption dialog:

You can select Figure or Table from the Label dropdown,

or create your own by clicking New Label… If you count

tables as artwork, then you can use Figure for all cap-

tions—check the RFP instructions and your company

style guide for clarification. You will probably also want

to include the major heading number, so click

Numbering…

To include the major heading number, or ‘chapter’ as

Word calls it, check Include chapter number and select

the heading level from the Chapter starts with style
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dropdown. You can insert each caption with a different

heading level, or one consistent level throughout. The

caption will have the heading value of the immediately

preceding ‘chapter’ number. For example, with Heading 1

selected as the Chapter starts with style, the first cap-

tion following section 4.2 in your document will be

Figure 4-1, the second Figure 4-2, etc.

A note about captions in frames. For those of you who

have attended any of my APMP presentations or work-

shops, and are using frames to place your art at specific

location on a page, there is an extra wrinkle. Word num-

bers the captions by the location of the paragraphs to

which the frames containing the captions are anchored.

So, if you see that the first framed caption has higher fig-

ure sequence number than the second framed caption,

you will have to swap the anchors around.

Another wrinkle is that, unlike automatically numbered

headings, captions will not automatically update them-

selves if another caption is inserted earlier in the docu-

ment, or if an earlier caption is removed. To update all

the captions in one go, press Ctrl+A to select all the doc-

ument text, and then press F9 to updates the fields used

in the captions.

Having inserted your first caption, you will see that the

Caption style is used. If you want to modify this style, go

to Format > Styles and Formatting… If Caption is not

in the list of Available Styles in use, select Custom… in

the Show dropdown at the bottom of the Styles and

Formatting task pane. Word will display the Format

Settings dialog:

With Available styles in the Category dropdown, check

Caption in the Styles to be visible list and click OK.

You can also use this dialog to exclude styles that you

don’t want other people, e.g. contributing authors, to see

in your template. Now the Caption style is visible in the

list of available styles, you can modify its properties.

Creating a Table of Figures

Similar to creating table of contents, you can easily cre-

ate a table of figures. Go to Insert > Reference >

Index and Tables… and select the Table of Figures tab:

Again, you will probably want to modify the appearance

of the table of figures. There is only one style, Table of

Figures, which you can access by clicking Modify… A

simple setting is to base this style on the TOC 1 style.
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Press F9 to update the table of figures, as you did for the
ToC.

Inserting a Cross Reference

Automatic numbering allows you to create cross refer-
ences to headings and figure captions that you can main-
tain by simply updating the fields. To insert a cross refer-
ence to a heading, go to Insert > Reference > Cross-
reference… Select Heading in the Reference type
dropdown, and Heading number in the Insert refer-
ence to dropdown:

Select the heading that you want to insert a cross refer-
ence to, and click Insert. To insert a cross reference to a
figure, e.g. “Figure 1-1 shows…,” select Figure in the
Reference type dropdown, and Only label and number
in the Insert reference to dropdown.

To update all the cross references (and figure captions) in
one hit, press Ctrl+A to select all the document text, and
then press F9 to updates the fields. If the target heading
or caption for a cross reference has been removed, Word
will display the “Error! Reference source not found.” mes-
sage in place of the cross reference, so check your docu-
ment carefully.

Advanced Numbering Schemes

With a bit of experimentation and practice, you can set
up two schemes within one numbering list. Here is an
example of a scheme using conventional legal numbering
for Heading 1 through Heading 6, and an appendix
scheme using for Heading 7 through Heading 9:

This was set up as described in the sections above up to
and including Heading 6. To create the Appendix A for-
mat for Heading 7:

■ Click 7 in the Level list

■ Delete the contents of the Number format text box.
The Number style dropdown value will change to (none)

■ In the Number format text box, type Appendix
followed by a space

■ Select A, B, C,… in the Number style dropdown.
This will insert a grey-shaded A at the end of the
Number format text box, representing the value
of the level 7 heading

■ Uncheck Restart numbering after

■ Select Heading 7 in the Link level to style dropdown

Now click 8 in the Level list, and delete the contents of
the Number format text box.

■ Select Level 7 in the Previous level number dropdown.
This will insert a gray-shaded A in the Number format
text box, representing the value of the level 7 heading

■ Type a period after the A in the Number format text box

■ Select 1, 2, 3,… in the Number style dropdown.
This will insert a grey-shaded 1 at the end of the
Number format text box, representing the value of
the level 8 heading
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■ Check Restart numbering after, and select Level 7
in the dropdown list

■ Select Heading 8 in the Link level to style dropdown

Now you have the idea, you should be able to create the
level 9 heading, which should display as A.1.1 etc. You
now have three levels of headings for your appendices.

When you insert a figure caption in an appendix, change
the numbering such that the chapter starts with style is
Heading 7. You will then get figure captions such as
Figure A-1, etc.

To get the appendix headings into the table of contents,
click Options… on the Table of Contents tab of the
Index and Table dialog. In the Table of Contents
Options dialog, scroll down the list of Available styles,
and type 1 in the TOC level box next to Heading 7, 2
next to Heading 8 and 3 next to Heading 9:

Click OK, and then OK again to create the ToC. You will

see that Appendix A appears as if it was a level 1 head-

ing. Creating a table of figures requires no extra effort, as

it is only based on the Figure label.

Summary
I hope that you now feel confident to set up your propos-

al templates using automatic heading numbering, and to

be able to explain how to use your new template to your

contributing authors. I’m sure that you will find that it

will save you time and energy at proposal end game!

Many thanks again to those of you who attended our ses-

sions at the recent APMP Conference in New Orleans.

Those of you who attended both (four and half hours

worth) should get a medal. But, once again, we got some

really interesting questions and learnt a few things our-

selves! The first question in the “Wordman and Acrobat

Girl’s Q&A” session was on preventing artwork from

moving around the page. Traditionally this has been the

first question in every Wordman session at a conference

since 2003! A tutorial article on the subject is long over-

due, and will feature in a future Wordman column.

I also had some feedback by email regarding my

“Logectomy” article in a recent Wordman column. Some

readers expressing their concerns about me the third-

party use of logos whose use is restricted by their owners.

Please note that my intention was merely to demonstrate

a useful technique. However if you are in any doubt,

please contact the owner of the logo.

If there’s a problem you’d like a solution for, or a subject

you’d like more information on, you can reach Wordman

via Dick Eassom, Director of Competition Management

Standards and Systems, at SM&A, Newport Beach,

California—e-mail Dick at dick.eassom@smawins.com.

Wordman is ©2001–2006 SM&A, and used with permis-

sion by APMP.  ■




